You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/neti/neti-2.0-r2.ebuild

56 lines
1.0 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
DESCRIPTION="NETI@Home research project from GATech"
HOMEPAGE="http://www.neti.gatech.edu"
SRC_URI="mirror://sourceforge/neti/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc x86"
IUSE="zlib java"
DEPEND="
java? ( || ( >=virtual/jdk-1.2 >=virtual/jre-1.2 ) )
net-libs/libpcap
sys-libs/zlib
"
RDEPEND="${DEPEND}"
RESTRICT="test"
src_configure() {
econf $(use_with zlib)
}
src_compile() {
emake NETILogParse neti
use java && emake javadir=/usr/share/${PN} classjava.stamp
}
src_install() {
emake \
DESTDIR="${D}" \
install-sbinPROGRAMS \
install-sysconfDATA \
install-man \
install-info
if use java; then
emake \
DESTDIR="${D}" \
javadir=/usr/share/${PN} \
install-javaJAVA \
install-javaDATA
echo cd /usr/share/${PN}\;java -cp /usr/share/${PN} NETIMap > "${WORKDIR}"/NETIMap
dobin "${WORKDIR}"/NETIMap
fi
dodoc README AUTHORS
newinitd "${FILESDIR}"/neti-init2 neti
}