You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-mathematics/eclib/eclib-20210625.ebuild

36 lines
870 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
HOMEPAGE="https://github.com/JohnCremona/eclib"
SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/${PV}/${P}.tar.bz2"
LICENSE="GPL-2"
# Major version of /usr/lib64/libec.so
SLOT="0/8"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="boost flint minimal static-libs test"
RESTRICT="!test? ( test )"
RDEPEND="sci-mathematics/pari:=
dev-libs/ntl:=
boost? ( dev-libs/boost:= )
flint? ( sci-mathematics/flint:= )"
DEPEND="${RDEPEND}"
src_configure() {
econf \
$(usex minimal --disable-allprogs "" "" "") \
$(use_with boost) \
$(use_with flint) \
$(use_enable static-libs static)
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}