You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/kbdd/kbdd-0.7.1.ebuild

33 lines
577 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit autotools vcs-snapshot
DESCRIPTION="Very simple layout switcher"
HOMEPAGE="https://github.com/qnikst/kbdd"
SRC_URI="https://github.com/qnikst/kbdd/tarball/v${PV} -> ${PN}-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dbus"
DEPEND="dev-libs/glib:2=
x11-libs/libX11:0=
dbus? (
sys-apps/dbus:0=
>=dev-libs/dbus-glib-0.86:0=
)
"
RDEPEND="${DEPEND}"
src_prepare() {
eautoreconf
}
src_configure() {
econf $(use_enable dbus)
}