You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Crypt-DSA/Crypt-DSA-1.170.0.ebuild

33 lines
751 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MODULE_AUTHOR=ADAMK
MODULE_VERSION=1.17
inherit perl-module
DESCRIPTION="DSA Signatures and Key Generation"
SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ppc sparc x86 ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-perl/Data-Buffer
dev-perl/Digest-SHA1
virtual/perl-File-Spec
dev-perl/File-Which
virtual/perl-MIME-Base64
>=virtual/perl-Math-BigInt-1.78"
DEPEND="test? ( ${RDEPEND}
dev-perl/Math-BigInt-GMP )"
SRC_TEST="do"
src_prepare() {
sed -i -e 's/use inc::Module::Install /use lib q[.]; use inc::Module::Install /' Makefile.PL ||
die "Can't patch Makefile.PL for 5.26 dot-in-inc"
perl-module_src_prepare
}