You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild

40 lines
961 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="create dependencies in makefiles using 'gcc -M'"
HOMEPAGE="https://www.x.org/wiki/ https://gitlab.freedesktop.org/xorg/util/gccmakedep"
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/util/gccmakedep.git"
inherit autotools git-r3
# x11-misc/util-macros only required on live ebuilds
LIVE_DEPEND=">=x11-misc/util-macros-1.18"
else
SRC_URI="https://www.x.org/releases/individual/util/${P}.tar.bz2"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="MIT"
SLOT="0"
IUSE=""
DEPEND="
${LIVE_DEPEND}
x11-base/xorg-proto
"
src_prepare() {
default
[[ ${PV} == 9999 ]] && eautoreconf
}
src_configure() {
local econfargs=(
--disable-selective-werror
)
econf "${econfargs[@]}"
}