You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/GridDataFormats/GridDataFormats-0.5.0.ebuild

33 lines
802 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Reading and writing of data on regular grids in Python"
HOMEPAGE="https://pypi.org/project/GridDataFormats/ https://github.com/MDAnalysis/GridDataFormats"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="LGPL-3"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
RDEPEND="
>=dev-python/numpy-1.0.3[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
python_prepare_all() {
# This test needs porting to newer numpy
sed -i -e 's/test_resample_factor/_&/' \
gridData/tests/test_grid.py || die
distutils-r1_python_prepare_all
}