You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/mab/mab-0.0.3-r1.ebuild

28 lines
541 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_TASK_TEST="test"
RUBY_FAKEGEM_EXTRADOC="README.md"
inherit ruby-fakegem
DESCRIPTION="Markup as Ruby"
HOMEPAGE="https://github.com/camping/mab"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="test"
ruby_add_bdepend "
test? ( >=dev-ruby/minitest-4:0 )"
all_ruby_prepare() {
sed -i -e '1igem "minitest", "~> 4.0"' test/helper.rb || die
}