You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/ruby2ruby/ruby2ruby-2.4.4.ebuild

33 lines
844 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
USE_RUBY="ruby25 ruby26 ruby27 ruby30"
RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
inherit ruby-fakegem
DESCRIPTION="Generates readable ruby from ParseTree"
HOMEPAGE="https://github.com/seattlerb/ruby2ruby"
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~alpha amd64 arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
IUSE="test"
ruby_add_rdepend "
>=dev-ruby/sexp_processor-4.6.0:4
>=dev-ruby/ruby_parser-3.1:3
"
ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.3:5 >=dev-ruby/sexp_processor-4.10.0:4 )"
all_ruby_prepare() {
sed -i -e '/plugin :isolate/ s:^:#:' Rakefile || die
}
each_ruby_test() {
${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
}