You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/temple/temple-0.8.2.ebuild

28 lines
632 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
USE_RUBY="ruby24 ruby25 ruby26 ruby27"
RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
RUBY_FAKEGEM_TASK_TEST=""
inherit ruby-fakegem
DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby"
HOMEPAGE="https://github.com/judofyr/temple"
LICENSE="MIT"
SLOT="0.7"
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 x86"
IUSE=""
ruby_add_bdepend "test? ( dev-ruby/bacon
dev-ruby/erubis
>=dev-ruby/tilt-2.0.1 )"
each_ruby_test() {
${RUBY} -S bacon -Ilib -Itest --automatic --quiet || die
}