You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-embedded/parapin/parapin-1.5.1_beta1-r1.ebuild

39 lines
739 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="A parallel port pin programming library"
HOMEPAGE="http://parapin.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P/_/-}.tgz"
S="${WORKDIR}/${P/_/-}"
LICENSE="LGPL-2.1"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="doc"
PATCHES=(
"${FILESDIR}"/${PN}-1.5.0-tc-directly.patch
)
src_compile() {
tc-export AR CC
# Note 2.4 and 2.6 makefiles are identical for the targets used
emake -f Makefile-2.4
}
src_install() {
einstalldocs
dolib.a libparapin.a
insopts -m0444; insinto /usr/include; doins parapin.h
if use doc; then
cd examples || die
docinto examples
dodoc *.c
fi
}