You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/wtforms/wtforms-3.0.1.ebuild

35 lines
802 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
MY_PN="WTForms"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Flexible forms validation and rendering library for python web development"
HOMEPAGE="https://wtforms.readthedocs.io/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-python/markupsafe[${PYTHON_USEDEP}]"
BDEPEND="
dev-python/Babel[${PYTHON_USEDEP}]
test? (
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/python-email-validator[${PYTHON_USEDEP}]
dev-python/sqlalchemy[${PYTHON_USEDEP}]
dev-python/webob[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest