You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ml/batteries/batteries-3.3.0.ebuild

28 lines
611 B

# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit findlib
DESCRIPTION="A community-maintained standard library extension"
HOMEPAGE="https://github.com/ocaml-batteries-team/batteries-included"
SRC_URI="https://github.com/ocaml-batteries-team/batteries-included/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="test"
DEPEND=""
RDEPEND="${DEPEND}
dev-ml/num:="
BDEPEND="dev-ml/ocamlbuild"
S="${WORKDIR}"/batteries-included-${PV}
src_install() {
findlib_src_install
}