You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/tomli-w/tomli-w-1.0.0.ebuild

27 lines
616 B

# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_SETUPTOOLS=pyproject.toml
PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="A lil' TOML writer"
HOMEPAGE="
https://pypi.org/project/tomli-w/
https://github.com/hukkin/tomli-w/"
SRC_URI="
https://github.com/hukkin/tomli-w/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv sparc x86"
BDEPEND="
test? ( dev-python/tomli[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest