You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/urwid_readline/urwid_readline-0.13.ebuild

24 lines
555 B

# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Text input widget for urwid that supports readline shortcuts"
HOMEPAGE="
https://github.com/rr-/urwid_readline/
https://pypi.org/project/urwid-readline/"
SRC_URI="
https://github.com/rr-/urwid_readline/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
RDEPEND="dev-python/urwid[${PYTHON_USEDEP}]"
distutils_enable_tests pytest