You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/wurlitzer/wurlitzer-3.0.2.ebuild

24 lines
473 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Capture C-level stdout/stderr in Python"
HOMEPAGE="
https://github.com/minrk/wurlitzer/
https://pypi.org/project/wurlitzer/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
distutils_enable_tests pytest
python_test() {
epytest test.py
}