You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1-r1....

28 lines
562 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby26 ruby27 ruby30"
inherit ruby-fakegem
DESCRIPTION="An HTTP/1.1 pipelining implementation atop Net::HTTP"
HOMEPAGE="http://docs.seattlerb.org/net-http-pipeline/"
LICENSE="MIT"
SLOT="1"
KEYWORDS="~amd64"
IUSE=""
ruby_add_bdepend "
test? ( dev-ruby/minitest )
"
all_ruby_prepare() {
eapply -p0 "${FILESDIR}/${PN}-accept-encoding.patch"
}
each_ruby_test() {
${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
}