You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/serialport/serialport-1.3.2.ebuild

35 lines
754 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby26 ruby27 ruby30"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
RUBY_FAKEGEM_EXTENSIONS=(ext/native/extconf.rb)
inherit multilib ruby-fakegem
DESCRIPTION="a library for serial port (rs232) access in ruby"
HOMEPAGE="https://github.com/hparra/ruby-serialport/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
all_ruby_prepare() {
# Fix the miniterm script so that it might actually work, we'll
# install it as example.
sed -i -e 's:\.\./serialport.so:serialport:' test/miniterm.rb || die
}
all_ruby_install() {
all_fakegem_install
dodoc test/miniterm.rb
}