You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kcrash/kcrash-5.89.0.ebuild

42 lines
821 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PVCUT=$(ver_cut 1-2)
QTMIN=5.15.2
VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="Framework for intercepting and handling application crashes"
LICENSE="LGPL-2+"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
IUSE="nls X"
# requires running Plasma environment
RESTRICT="test"
RDEPEND="
>=dev-qt/qtgui-${QTMIN}:5
=kde-frameworks/kcoreaddons-${PVCUT}*:5
=kde-frameworks/kwindowsystem-${PVCUT}*:5
X? (
>=dev-qt/qtx11extras-${QTMIN}:5
x11-libs/libX11
)
"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
"
BDEPEND="
nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
"
src_configure() {
local mycmakeargs=(
-DWITH_X11=$(usex X)
)
ecm_src_configure
}