You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-libs/argp-standalone/argp-standalone-1.4.1-r1.eb...

43 lines
818 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools flag-o-matic
DESCRIPTION="Standalone argp library for use with musl"
HOMEPAGE="https://github.com/ericonr/argp-standalone"
SRC_URI="https://github.com/ericonr/argp-standalone/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="public-domain GPL-2 GPL-3 XC"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~x86"
IUSE="static-libs"
DEPEND="!sys-libs/glibc"
PATCHES=(
"${FILESDIR}"/argp-standalone-1.3-shared.patch
)
src_prepare() {
default
eautoreconf
}
src_configure() {
append-cflags "-fgnu89-inline"
econf $(use_enable static-libs static)
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
insinto /usr/include
doins argp.h
}