You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/unclutter/unclutter-8-r4.ebuild

36 lines
759 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="Hides mouse pointer while not in use"
HOMEPAGE="http://www.ibiblio.org/pub/X11/contrib/utilities/unclutter-8.README"
SRC_URI="ftp://ftp.x.org/contrib/utilities/${P}.tar.Z"
SLOT="0"
LICENSE="public-domain"
KEYWORDS="~alpha amd64 ~hppa ~mips ppc ppc64 ~sparc x86"
RDEPEND="x11-libs/libX11"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
S=${WORKDIR}/${PN}
PATCHES=(
"${FILESDIR}"/${P}-include.patch
"${FILESDIR}"/${P}-FocusOut.patch
)
src_compile() {
emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" LDOPTIONS="${LDFLAGS}"
}
src_install() {
dobin unclutter
newman unclutter.man unclutter.1x
einstalldocs
}