You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild

48 lines
800 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="A utility that displays its input in a text box on your root window"
HOMEPAGE="https://sourceforge.net/projects/xrootconsole/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
RDEPEND="
x11-libs/libX11"
DEPEND="
${RDEPEND}
x11-base/xorg-proto
virtual/pkgconfig
"
PATCHES=(
"${FILESDIR}/${P}.noversion.patch"
"${FILESDIR}/${P}.makefile.patch"
"${FILESDIR}/${P}.manpage.patch"
)
DOCS=( TODO NEWS CREDITS )
src_compile() {
tc-export CC PKG_CONFIG
emake
}
src_install() {
dodir /usr/bin
emake \
MANDIR="${D}usr/share/man/man1" \
BINDIR="${D}usr/bin/" \
install
einstalldocs
}