You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/mustache/mustache-2.4.0.ebuild

44 lines
1.1 KiB

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.7.1.1.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="A mustache template parser library"
HOMEPAGE="https://github.com/JustusAdam/mustache"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
PATCHES=(
"${FILESDIR}/${PN}-2.3.2-disable-langspec-tests.patch"
"${FILESDIR}/${PN}-2.4.0-ghc-8_10-fix.patch"
"${FILESDIR}/${PN}-2.4.0-unordered-containers-2_17-fix.patch"
)
RDEPEND="dev-haskell/aeson:=[profile?]
dev-haskell/cmdargs:=[profile?]
dev-haskell/scientific:=[profile?]
dev-haskell/th-lift:=[profile?]
dev-haskell/unordered-containers:=[profile?]
dev-haskell/vector:=[profile?]
dev-haskell/yaml:=[profile?]
>=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
test? ( dev-haskell/base-unicode-symbols
dev-haskell/hspec
dev-haskell/lens
dev-haskell/tar
dev-haskell/temporary
dev-haskell/wreq
dev-haskell/zlib )
"