You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/qtdeclarative/qtdeclarative-6.3.1.ebuild

31 lines
521 B

# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit qt6-build
DESCRIPTION="Qt Declarative (Quick 2)"
if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64"
fi
IUSE="opengl +sql +widgets"
DEPEND="
=dev-qt/qtbase-${PV}*[network,opengl=,sql=,widgets=]
=dev-qt/qtshadertools-${PV}*
"
RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
$(qt_feature opengl)
$(qt_feature sql)
$(qt_feature widgets)
)
qt6-build_src_configure
}