You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/cattrs/cattrs-22.1.0.ebuild

58 lines
1.2 KiB

# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=poetry
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Composable complex class support for attrs and dataclasses"
HOMEPAGE="
https://pypi.org/project/cattrs/
https://github.com/python-attrs/cattrs/
"
SRC_URI="
https://github.com/python-attrs/cattrs/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
RDEPEND="
>=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
dev-python/exceptiongroup[${PYTHON_USEDEP}]
' 3.8 3.9 3.10)
"
BDEPEND="
test? (
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/immutables[${PYTHON_USEDEP}]
)
"
# test_preconf:
# dev-python/bson[${PYTHON_USEDEP}]
# dev-python/msgpack[${PYTHON_USEDEP}]
# dev-python/orjson[${PYTHON_USEDEP}]
# dev-python/pyyaml[${PYTHON_USEDEP}]
# dev-python/tomlkit[${PYTHON_USEDEP}]
# dev-python/ujson[${PYTHON_USEDEP}]
distutils_enable_tests pytest
src_prepare() {
sed -e 's:--benchmark.*::' \
-e '/addopts/d' \
-i pyproject.toml || die
distutils-r1_src_prepare
}
python_test() {
# unpackaged deps, see above
epytest tests --ignore tests/test_preconf.py
}