You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/www-plugins/browserpass/browserpass-3.0.10.ebuild

44 lines
1.3 KiB

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit go-module
MY_PN=browserpass-native
DESCRIPTION="WebExtension host binary for app-admin/pass, a UNIX password manager"
HOMEPAGE="https://github.com/browserpass/browserpass-native"
SRC_URI="https://github.com/browserpass/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
https://dev.gentoo.org/~mattst88/distfiles/${P}-deps.tar.xz"
LICENSE="BSD ISC MIT"
SLOT="0"
KEYWORDS="~amd64"
RDEPEND="app-crypt/gnupg"
S="${WORKDIR}"/${MY_PN}-${PV}
src_compile() {
ego build || die
sed -e 's|%%replace%%|'${EPREFIX}'/usr/libexec/browserpass-native|' \
-i browser-files/firefox-host.json browser-files/chromium-host.json || die
}
src_install() {
exeinto /usr/libexec
doexe browserpass-native
insinto /usr/lib/mozilla/native-messaging-hosts
newins browser-files/firefox-host.json com.github.browserpass.native.json
insinto /usr/lib64/mozilla/native-messaging-hosts
newins browser-files/firefox-host.json com.github.browserpass.native.json
insinto /etc/chromium/native-messaging-hosts
newins browser-files/chromium-host.json com.github.browserpass.native.json
insinto /etc/opt/chrome/native-messaging-hosts
newins browser-files/chromium-host.json com.github.browserpass.native.json
}