You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/hashtables/hashtables-1.3.ebuild

45 lines
1.5 KiB

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.7.1.1.9999
#hackport: flags: sse42:cpu_flags_x86_sse4_2,+unsafe-tricks,-portable
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Mutable hash tables in the ST monad"
HOMEPAGE="https://github.com/gregorycollins/hashtables"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="bounds-checking cpu_flags_x86_sse4_2 debug detailed-profiling"
RDEPEND=">=dev-haskell/hashable-1.4:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
dev-haskell/primitive:=[profile?]
>=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.13:=[profile?]
>=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
>=dev-haskell/mwc-random-0.8 <dev-haskell/mwc-random-0.16
>=dev-haskell/quickcheck-2.3.0.2
>=dev-haskell/test-framework-0.3.1 <dev-haskell/test-framework-0.9
>=dev-haskell/test-framework-hunit-0.2.6 <dev-haskell/test-framework-hunit-3
>=dev-haskell/test-framework-quickcheck2-0.2.6 <dev-haskell/test-framework-quickcheck2-0.4 )
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bounds-checking bounds-checking) \
$(cabal_flag debug debug) \
$(cabal_flag detailed-profiling detailed-profiling) \
--flag=-portable \
$(cabal_flag cpu_flags_x86_sse4_2 sse42) \
--flag=unsafe-tricks
}