You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/pystache/pystache-0.6.1.ebuild

43 lines
854 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Updated Python implementation of Mustache templating framework"
HOMEPAGE="
https://github.com/PennyDreadfulMTG/pystache/
https://pypi.org/project/pystache/
"
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/PennyDreadfulMTG/pystache.git"
EGIT_BRANCH="master"
inherit git-r3
else
SRC_URI="
https://github.com/PennyDreadfulMTG/pystache/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
LICENSE="MIT"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/pyyaml[${PYTHON_USEDEP}]
)
"
python_test() {
pystache-test || die "Test failed with ${EPYTHON}"
}