You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ml/sedlex/sedlex-2.5.ebuild

38 lines
739 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit dune
DESCRIPTION="An OCaml lexer generator for Unicode"
HOMEPAGE="https://github.com/ocaml-community/sedlex"
SRC_URI="https://github.com/ocaml-community/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+ocamlopt"
DEPEND="
dev-ml/gen:=
dev-ml/ppxlib:=
dev-ml/uchar:=
"
RDEPEND="${DEPEND}"
src_compile() {
ebegin "Building"
dune build @install --display short --profile release \
--ignore-promoted-rules
eend $? || die
}
dune_src_test() {
ebegin "Testing"
dune runtest --display short --profile release \
--ignore-promoted-rules
eend $? || die
}