You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/docutils-glep/docutils-glep-1.4.ebuild

29 lines
747 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=flit
PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Gentoo GLEP support for docutils"
HOMEPAGE="
https://github.com/projg2/docutils-glep/
https://pypi.org/project/docutils-glep/
"
SRC_URI="
https://github.com/projg2/docutils-glep/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
RDEPEND="
>=dev-python/docutils-0.10[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
"