You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/guessit/guessit-3.4.3.ebuild

43 lines
964 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Python library for guessing information from video filenames"
HOMEPAGE="
https://github.com/guessit-io/guessit/
https://pypi.org/project/guessit/
"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
RDEPEND="
>=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
>=dev-python/rebulk-3[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
dev-python/importlib_resources[${PYTHON_USEDEP}]
' 3.8)
"
BDEPEND="
test? (
dev-python/pytest-mock[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest
EPYTEST_IGNORE=(
# Disable benchmarks as they require unavailable pytest-benchmark.
guessit/test/test_benchmark.py
)