You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/pathvalidate/pathvalidate-2.5.1.ebuild

28 lines
626 B

# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A Python library to sanitize/validate a string such as filenames/file-paths/etc"
HOMEPAGE="https://github.com/thombashi/pathvalidate"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/allpairspy[${PYTHON_USEDEP}]
dev-python/tcolorpy[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest