You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/makefun/makefun-1.15.2.ebuild

31 lines
612 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="Small library to dynamically create Python functions"
HOMEPAGE="
https://pypi.org/project/makefun/
https://github.com/smarie/python-makefun/
"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
src_prepare() {
sed -e '/pytest-runner/d' -i setup.cfg || die
distutils-r1_src_prepare
}