You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/marshmallow/marshmallow-3.20.1.ebuild

37 lines
780 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="A library for converting to and from native Python datatypes"
HOMEPAGE="
https://github.com/marshmallow-code/marshmallow/
https://pypi.org/project/marshmallow/
"
SRC_URI="
https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
RDEPEND="
>=dev-python/packaging-0.17[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/simplejson[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest