You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/mkdocs-static-i18n/mkdocs-static-i18n-1.2.0.eb...

32 lines
625 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517="hatchling"
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="MkDocs i18n plugin using static translation markdown files"
HOMEPAGE="
https://github.com/ultrabug/mkdocs-static-i18n
https://pypi.org/project/mkdocs-static-i18n/
"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~riscv x86"
RDEPEND="
>=dev-python/mkdocs-1.5.2[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/mkdocs-material[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest