You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-proxy/haproxy-dataplaneapi/haproxy-dataplaneapi-2.5.1....

28 lines
636 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit go-module
DESCRIPTION="haproxy dataplane api / sidecar"
HOMEPAGE="https://github.com/haproxytech/dataplaneapi https://www.haproxy.com/documentation/dataplaneapi/latest/"
SRC_URI="https://github.com/haproxytech/dataplaneapi/archive/v${PV}.tar.gz -> ${P}.tar.gz
http://gentooexperimental.org/~patrick/${P}-deps.tar.xz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
S="${WORKDIR}/dataplaneapi-${PV}"
src_compile() {
GOBIN="${S}/bin" emake build
}
src_install() {
dobin build/dataplaneapi
dodoc README.md
}