You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2...

26 lines
564 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_BINWRAP=""
inherit ruby-fakegem
DESCRIPTION="Set of matchers and helpers to allow you test your APIs responses"
HOMEPAGE="https://github.com/waterlink/rspec-json_expectations"
LICENSE="MIT"
SLOT="1"
KEYWORDS="amd64 ~x86"
IUSE=""
ruby_add_bdepend "test? ( dev-ruby/rspec dev-util/cucumber )"
each_ruby_test() {
${RUBY} -S cucumber --format progress features || die
}