You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sec-keys/openpgp-keys-thomasdickey/openpgp-keys-thomasdickey-2...

20 lines
646 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="OpenPGP keys used by Thomas Dickey"
HOMEPAGE="https://invisible-island.net/public/public.html"
SRC_URI="https://invisible-island.net/public/dickey@invisible-island.net-rsa3072.asc -> ${P}-dickey@invisible-island.net-rsa3072.asc"
S="${WORKDIR}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
src_install() {
local files=( ${A} )
insinto /usr/share/openpgp-keys
newins - thomasdickey.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
}