You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/gnome-extra/cinnamon-menus/cinnamon-menus-6.0.0.ebuild

38 lines
819 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit meson xdg
DESCRIPTION="Cinnamon's library for the Desktop Menu fd.o specification"
HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cinnamon-menus"
SRC_URI="https://github.com/linuxmint/cinnamon-menus/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
IUSE="gtk-doc"
RDEPEND="
>=dev-libs/glib-2.29.15:2
>=dev-libs/gobject-introspection-1.58.3:=
"
DEPEND="
${RDEPEND}
dev-libs/gobject-introspection-common
"
BDEPEND="
sys-devel/gettext
virtual/pkgconfig
gtk-doc? ( dev-util/gtk-doc )
"
src_configure() {
local emesonargs=(
$(meson_use gtk-doc enable_docs)
)
meson_src_configure
}