You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/gnome-extra/polkit-gnome/polkit-gnome-0.105-r2.ebuild

45 lines
1.0 KiB

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit gnome.org
DESCRIPTION="A dbus session bus service that is used to bring up authentication dialogs"
HOMEPAGE="https://gitlab.freedesktop.org/polkit/polkit/"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
IUSE=""
DEPEND=">=dev-libs/glib-2.30
>=sys-auth/polkit-0.102
x11-libs/gtk+:3"
RDEPEND="${DEPEND}"
BDEPEND="dev-util/intltool
virtual/pkgconfig
sys-devel/gettext"
DOCS=( AUTHORS HACKING NEWS README TODO )
src_install() {
default
cat <<-EOF > "${T}"/polkit-gnome-authentication-agent-1.desktop
[Desktop Entry]
Name=PolicyKit Authentication Agent
Comment=PolicyKit Authentication Agent
Exec=/usr/libexec/polkit-gnome-authentication-agent-1
Terminal=false
Type=Application
Categories=
NoDisplay=true
NotShowIn=MATE;KDE;
AutostartCondition=GNOME3 if-session gnome-fallback
EOF
insinto /etc/xdg/autostart
doins "${T}"/polkit-gnome-authentication-agent-1.desktop
}