You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-radio/cwdaemon/cwdaemon-0.11.0.ebuild

25 lines
568 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit flag-o-matic
DESCRIPTION="A morse daemon for the parallel or serial port"
HOMEPAGE="http://cwdaemon.sourceforge.net"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc x86"
RDEPEND=">=media-radio/unixcw-3.3.1"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_configure() {
# provides header info for getaddrinfo() with C99 (bug 569970)
append-cppflags -D_GNU_SOURCE
econf
}