You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-irc/dccserver/dccserver-0.5-r2.ebuild

31 lines
602 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Linux implementation of the mirc dccserver command"
HOMEPAGE="https://www.nih.at/dccserver/"
SRC_URI="https://www.nih.at/dccserver/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc ~riscv x86"
RDEPEND="dev-libs/libbsd"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/${P}-include-bsd-string-header.patch" )
src_prepare() {
default
# Respect AR
sed -i -e "s/AR = /AR ?= /" lib/Makefile.in || die
}
src_compile() {
AR="$(tc-getAR)" default
}