You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-irc/ircmap/ircmap-0.99-r1.ebuild

47 lines
1.1 KiB

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Scripts to treate diagrams of IRC networks using the LINKS command"
HOMEPAGE="http://pasky.or.cz/irc/"
SRC_URI="http://pasky.or.cz/irc/${PN}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 x86"
RDEPEND="
media-gfx/graphviz
dev-lang/perl
"
BDEPEND="${RDEPEND}"
src_compile() {
sed -i \
-e "s:/home/pasky/ircmap:/usr/share/ircmap:" \
{ircmapC,ircmapR-aa,ircmapR-gvdot,ircmapR-ircnet,ircmapS}.pl
}
src_install() {
dodoc README
dobin ircmapS.pl ircmapC.pl ircmapR-aa.pl ircmapR-gvdot.pl ircmapR-ircnet.pl
insinto /usr/share/ircmap
doins IHash.pm
}
pkg_postinst() {
elog 'Usage:'
elog 'IRCSERVER="irc.generic.com ircmapS.pl [-options parameters] \'
elog '| tee /tmp/sendmethisifitdoesntwork \'
elog '| ircmapC.pl \'
elog '| tee /tmp/coredump \'
elog '| ircmapR-aa.pl > ${IRCSERVER}.txt'
elog ''
elog 'cat /tmp/coredump \'
elog '| ircmapR-gvdot.pl \'
elog '| dot -Tgif -o ${IRCSERVER}.gif'
}