You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-irc/sic/sic-1.2-r1.ebuild

41 lines
753 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="An extremely simple IRC client"
HOMEPAGE="https://tools.suckless.org/sic"
SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~riscv x86"
PATCHES=(
"${FILESDIR}/${PN}-1.2-include-path.patch"
"${FILESDIR}/${PN}-1.2-musl-time-include.patch"
)
src_prepare() {
default
sed -i \
-e '/^CFLAGS/{s: -Os::g; s:= :+= :g}' \
-e '/^CC/d' \
-e '/^LDFLAGS/{s:-s::g; s:= :+= :g}' \
config.mk || die
sed -i \
-e 's|@${CC}|$(CC)|g' \
Makefile || die
}
src_compile() {
emake CC="$(tc-getCC)"
}
src_install() {
emake DESTDIR="${ED}" PREFIX="/usr" install
}