You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-astronomy/pal/pal-0.9.8.ebuild

35 lines
788 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Positional Astronomy Library"
HOMEPAGE="https://github.com/Starlink/pal"
SRC_URI="https://github.com/Starlink/${PN}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"
RDEPEND="sci-astronomy/erfa:="
DEPEND="${RDEPEND}"
src_configure() {
econf --without-starlink \
--without-stardocs \
--with-erfa \
$(use_enable static-libs static)
}
src_install() {
default
# remove cruft from non-fhs compliant
dodoc -r "${ED}"/usr/{docs,manifests,news}
rm -r "${ED}"/usr/{docs,manifests,news} || die
if ! use static-libs; then
find "${ED}" -name '*.la' -delete || die
fi
}