You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-calculators/calcoo/calcoo-1.3.18-r1.ebuild

38 lines
749 B

# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit autotools eutils
DESCRIPTION="Scientific calculator designed to provide maximum usability"
HOMEPAGE="http://calcoo.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}
virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${P}-gold.patch )
src_prepare() {
default
mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
econf --disable-gtktest
}
src_install() {
default
newicon src/pixmaps/main.xpm ${PN}.xpm
make_desktop_entry ${PN} Calcoo ${PN} "Education;Math"
}